Page 1 of 1

Closing the Browser not changes status

PostPosted: 03 Nov 2014, 03:51
by Idodesigns
In arrowchat, when a user closes the browser his status remains unchanged for several hours. When the browser is open and user is idle, the status changes successfully. Issue is only when the browser is closed. What's the solution for this? Reducing the online timeout doesn't worked.

Please reply the solution.

Thanks in Adavnce

PostPosted: 04 Nov 2014, 02:09
by Martok
Untrue. When a user closes the browser he disappears from chat and the online list after a few minutes.

PostPosted: 07 Nov 2014, 02:35
by Idodesigns
That may be true, but unfortunately I didn't get that working. Once a member logged in and closed the browser,and when checked after around 10-15 hours, still it shows online. That's why I posted it here. Is any customization required for that or is a default feature?

PostPosted: 07 Nov 2014, 11:03
by Jason
Unless you've altered the admin panel's configuration settings or the includes/integration.php file, I can't think of any other way that would happen.

PostPosted: 12 Nov 2014, 23:26
by Idodesigns
Sorry.. A small misunderstanding between status and session_time made me confused. User becomes offline perfectly. Sorry for the disturbance and thanks for the help.

Re: Closing the Browser not changes status

PostPosted: 13 Sep 2019, 19:43
by zoxtrix
I'm using v2.2 and it indeed exhibits a peculiar user status indicator behavior. I have the idle timeout setting at the default of 3 minutes, which is exactly when a user's status icon correctly changes to the inactive symbol (after no mouse/keyboard activity). However, after 2 more minutes the same user's status icon changes back to the active green circle on its own. This behavior is consistently repeatable.

Re: Closing the Browser not changes status

PostPosted: 14 Sep 2019, 09:28
by zoxtrix
zoxtrix wrote:I'm using v2.2 and it indeed exhibits a peculiar user status indicator behavior. I have the idle timeout setting at the default of 3 minutes, which is exactly when a user's status icon correctly changes to the inactive symbol (after no mouse/keyboard activity). However, after 2 more minutes the same user's status icon changes back to the active green circle on its own. This behavior is consistently repeatable.
Although I have noticed the above described behavior since I installed ArrowChat, it has not been a terribly important issue for me. I thus refrained from investigating it until today. As it turns out, the behavior is not a problem with ArrowChat at all. My installation of ArrowChat actually works quite well as far as user status notifications. So the behavior I've described is a non-issue! In my case, it is caused by a particular page of my website that's loaded on a separate browser tab which is configured to auto-refresh every 60 seconds. That's why my ArrowChat session (from the standpoint of another user's connection) changes from idle status to active status so frequently. Again, the described problem does NOT exist. I should have investigated it prior to commenting on it here. I apologize.