Get all the latest news about ArrowChat here
User avatar
Glocky
Customer
 
Posts: 17
Joined: 26 Feb 2015, 10:20

by Glocky 26 May 2015, 11:51

Martok wrote:
Jason wrote:The group permissions are very easy to setup; it just reads them from your database and puts it all into arrays. You can look at the includes/functions/integrations/ folder for just about every example you'd ever come across.

Glocky is in the same position as other XenForo users, the permissions as they are currently implemented won't work with how XenForo group permissions are designed to be used.

The order of instructions for upgrading isn't quite right, at least for XenForo. The integrations file needs to be step 4 before updating the theme - the admin panel throws a blank page until this is done (it did for me anyway).



Indeed, it's harder than you may think to do.
The permissions set is complex and this is not easy to get to interact.
I'll try again, but each time - I face the same issues.
It doesn't like it.
User avatar
Martok
Customer
 
Posts: 71
Joined: 26 Jun 2012, 12:04

by Martok 26 May 2015, 13:35

Glocky wrote:Indeed, it's harder than you may think to do.
The permissions set is complex and this is not easy to get to interact.
I'll try again, but each time - I face the same issues.
It doesn't like it.

Forget the permissions in ArrowChat, they simply will not work as required if you have your XenForo permissions set in the correct way. I'm not bothering to use them until ArrowChat has changed thrm so they work with XenForo.
User avatar
Glocky
Customer
 
Posts: 17
Joined: 26 Feb 2015, 10:20

by Glocky 26 May 2015, 14:32

Martok wrote:
Glocky wrote:Indeed, it's harder than you may think to do.
The permissions set is complex and this is not easy to get to interact.
I'll try again, but each time - I face the same issues.
It doesn't like it.

Forget the permissions in ArrowChat, they simply will not work as required if you have your XenForo permissions set in the correct way. I'm not bothering to use them until ArrowChat has changed thrm so they work with XenForo.


Indeed I may do that instead.
Does everything else besides that work?
As I encountered some issues including a blank screen :-/
User avatar
CBarnett
Customer
 
Posts: 4
Joined: 22 Mar 2015, 06:35

by CBarnett 26 May 2015, 15:15

Glocky wrote:
Indeed I may do that instead.
Does everything else besides that work?
As I encountered some issues including a blank screen :-/


When upgrading I ran into a blank screen issue. I am on IPB v4. However, there may be similarities in our issues. I simply went into my database and dropped all arrow chat tables, removed all arrow chat files via FTP and then ran a fresh arrow chat install for version 1.8.3. After that everything was fixed except for an avatar issue which shows as fixed in my bug report (just waiting to find out where I can download the fix to apply to my site).

If possible, I would recommend doing the same if you have access to PhPMyAdmin and just do a drop of arrow chat and remove old AC files with FTP then do a complete fresh install.
User avatar
Glocky
Customer
 
Posts: 17
Joined: 26 Feb 2015, 10:20

by Glocky 26 May 2015, 15:52

CBarnett wrote:
Glocky wrote:
Indeed I may do that instead.
Does everything else besides that work?
As I encountered some issues including a blank screen :-/


When upgrading I ran into a blank screen issue. I am on IPB v4. However, there may be similarities in our issues. I simply went into my database and dropped all arrow chat tables, removed all arrow chat files via FTP and then ran a fresh arrow chat install for version 1.8.3. After that everything was fixed except for an avatar issue which shows as fixed in my bug report (just waiting to find out where I can download the fix to apply to my site).

If possible, I would recommend doing the same if you have access to PhPMyAdmin and just do a drop of arrow chat and remove old AC files with FTP then do a complete fresh install.


Hello,
Okay thanks for the info.
Yes we have a vps so PhPMyAdmin access is readily available.
Indeed I think dropping the tables is the best way.

After rolling back, I now have issues comlaining of chats doubling up on themselves. So I need to drop the lot either way I think.

Thanks for the information, much appreciated. Will try that.
Thank you.
User avatar
Martok
Customer
 
Posts: 71
Joined: 26 Jun 2012, 12:04

by Martok 26 May 2015, 16:46

Glocky wrote:
Martok wrote:Does everything else besides that work?
As I encountered some issues including a blank screen :-/

Yes, although you need to place the integrations.php file before accessing the control panel to update the theme, not after as stated in the upgrade iinstructions. Not doing so means you'll get a blank pages when trying to access the admin panel.

For now, I'm using conditionals to hide the chat bar from certain groups. It's not as good as having user group permissions in Arrowchat but it will do for now. If you want to do the same and need details, send me a PM on the XenForo site.
User avatar
Glocky
Customer
 
Posts: 17
Joined: 26 Feb 2015, 10:20

by Glocky 26 May 2015, 18:23

Martok wrote:Yes, although you need to place the integrations.php file before accessing the control panel to update the theme, not after as stated in the upgrade iinstructions. Not doing so means you'll get a blank pages when trying to access the admin panel.

For now, I'm using conditionals to hide the chat bar from certain groups. It's not as good as having user group permissions in Arrowchat but it will do for now. If you want to do the same and need details, send me a PM on the XenForo site.


Okay thank you as always Martok.
:)
User avatar
DLampi
Customer
 
Posts: 5
Joined: 03 Jul 2011, 17:22

by DLampi 26 May 2015, 20:43

DLampi wrote:I downloaded the v1.8.3 and it wouldn't even unzip correctly. Should I start with a different file for a fresh install?


Would like to get this installation completed - anyone have a tip?
Should I use a different file for a fresh install?
Is the error likely a corrupt download?
Could the problem be with my computer?
Has anyone had this trouble before?
Does support check this thread to reply to trouble calls?
Should I be asking my questions some place else?
User avatar
DLampi
Customer
 
Posts: 5
Joined: 03 Jul 2011, 17:22

by DLampi 28 May 2015, 12:56

DLampi wrote:
DLampi wrote:I downloaded the v1.8.3 and it wouldn't even unzip correctly. Should I start with a different file for a fresh install?


Would like to get this installation completed - anyone have a tip?
Should I use a different file for a fresh install?
Is the error likely a corrupt download?
Could the problem be with my computer?
Has anyone had this trouble before?
Does support check this thread to reply to trouble calls?
Should I be asking my questions some place else?


Shall I request a refund via paypal?
User avatar
Martok
Customer
 
Posts: 71
Joined: 26 Jun 2012, 12:04

by Martok 28 May 2015, 15:17

DLampi wrote:I downloaded the v1.8.3 and it wouldn't even unzip correctly. Should I start with a different file for a fresh install?

Have you tried re-downloading the zip file again and then attempting to upgrade with the new one? If not, do so, downloaded files can get corrupted sometimes.
User avatar
gilbertgrape
Trial
 
Posts: 2
Joined: 18 May 2015, 19:57

by gilbertgrape 28 May 2015, 15:23

Seems they don't reply despite being on

I'd redownload the file.
If that doesn't work, ask someone else to download it and make it a .rar and send it to you.

Could be your computer. Could have been virus/malware. Could be you accidentally turned off the zip support.

Try searching and replacing ZipFileFix.reg that could possibly be it.
User avatar
Lovinity
Customer
 
Posts: 1
Joined: 23 May 2015, 23:04

by Lovinity 09 Jun 2015, 05:00

I'm really liking the version 1.8.3 of Arrowchat so far. I have it integrated with the ocPortal system (required some custom code modifications to get almost fully working). I do have a few concerns though:

*I would like to see the ability to assign groups as moderators or administrators. That way, via. group integration with ocPortal, my ocPortal moderators and administrators can automatically get mod/admin status in Arrowchat .

*iframe embedding doesn't seem to be 100% functional, specifically the chat rooms. For some reason, iframe chat rooms embedded in my ocPortal pages are not updating / checking for messages as they should. It works fine in the chat bar though, and even in the pop out chat.

*I've noticed if a user becomes inactive for a period of time and their session on ocPortal expires, then when they send a message to a user, they appear as a guest to the other user (though they're still logged in on Arrowchat and thus bypassing guest restrictions). In addition, then when a user tries to reply to said guest, they don't successfully get the message. The user has to message them via. their actual username in the IM.

*If someone has multiple tabs open in their browser pointing to different pages on the site, this may screw up their IM. If a user sends them a new message, it may appear on one of the tabs but not all of them. This bug was tested on Windows 7 with Google Chrome 43.

*On Android 5 (at least, haven't tested others), when using mobile IM page, going to an IM conversation with a user and then trying to go back to the main mobile arrowchat IM page results in a blank white page until it's reloaded via the chat tab on the ocPortal website.

*It's not easy to report inappropriate IMs on mobile like you can on desktop version... I don't even know if it's possible.

*I randomly get notices in my Arrowchat admin panel about an upgrade being available, but upon going to the upgrade page, it says I have the latest version (1.8.3).

There's probably more to say that I can't remember right now but I'll let you know when I remember. Thanks for reading!
User avatar
Martok
Customer
 
Posts: 71
Joined: 26 Jun 2012, 12:04

by Martok 20 Jul 2015, 17:16

Is there any news on changing group permissions so that they will work with how XenForo permissions are designed to be used? Currently Arrowchat user group permissions can't be used on XenForo sites that want to restrict Arrowchat to certain user groups.
User avatar
Summit14
Customer
 
Posts: 13
Joined: 08 May 2015, 00:27

by Summit14 20 Aug 2015, 23:29

Since the newest update, I haven't been able to use this system at all. So please fix the group permissions for XenForo