Find out what the new version changed here
User avatar
Jason
ArrowChat Team
 
Posts: 2031
Joined: 13 Dec 2009, 00:06

by Jason 03 Mar 2011, 21:22

General
  • Upgrade jQuery version to 1.5.1

Bug Fixes
  • FINALLY! - FireFox no longer displays "Waiting for..." and Opera will no longer spin.
  • Made the heart beat configuration a dynamic variable so that a cache refresh is not necessary.
  • The admin logout link should now work correctly.
  • Fixed a bug in the receive core with arrays.
  • SocialEngine 4.1.2 avatars now work.

Upgrade Instructions

You can try to use the automatic upgrade process from your ArrowChat admin panel under the "Update" navigation. If that process fails, you can update ArrowChat by following these instructions:

1. Download ArrowChat from http://www.arrowchat.com/members/index.php?do=purchases
2. Extract files
3. Delete the arrowchat/config.php file and install folder. You can also delete the "themes", "language", and "applications" folders if you have custom edits.
4. Copy and overwrite all files onto your server.

Files changed in this version:

arrowchat/external.php
arrowchat/version.php
arrowchat/admin/index.php
arrowchat/includes/functions_receive_socialengine4.php
arrowchat/includes/js/arrowchat_core.js
arrowchat/includes/js/arrowchat_libraries.js
arrowchat/includes/js/jquery.js
arrowchat/includes/js/jquery-1.3.2.min.js
arrowchat/popout/js/popout_core.js
arrowchat/popout/js/popout_libraries.js
arrowchat/receive/receive_core.php

Temporary solution to cache problems:

Update your ArrowChat footer template to include a "&v=1.0.5" at the end of the src attribute. The type=djs does NOT need this.
Code: Select all


We've also updated the jQuery version. If you want, you can update the header template to read "jquery.js?v=1.5.1" (Note the question mark!).

SocialEngine 4.1.2+ Users
Rename the includes/functions_receive_socialengine4.php file to functions_receive.php. Overwrite changes.
User avatar
Staff Bot
ArrowChat Team
 
Posts: 8996
Joined: 07 Nov 2012, 21:41

by Staff Bot 07 Nov 2012, 20:40

This thread has been locked because the last post is greater than six months old. There is a good chance that the information in this thread is outdated. Please open a new topic if you wish to discuss this further.